<!DOCTYPE html><html lang="nl" xml:lang="nl">
    <head>
        <title>In welke gevallen is C beter? - Computerworld</title><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" >
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=10" >
<meta name="viewport" content="initial-scale=1, width=device-width, user-scalable=no" >
<meta property="og:site_name" content="Computerworld" >
<meta name="twitter:card" content="summary" >
<meta name="twitter:site" content="@NLComputerworld" >
<meta name="twitter:creator" content="@NLComputerworld" >
<meta property="fb:app_id" content="225412434140008" >
<meta property="fb:page_id" content="172466899432883" >
<meta name="description" content="Soms is [x] beter, soms ben je beter af met C. Maar in welke gevallen precies? Aan de hand van vergelijkingen met andere talen kijken we waarom programmeertaal C nog steeds heerst." >
<meta name="keywords" content="programmeertaal,programmeren" >
<meta name="news_keywords" content="programmeertaal,programmeren" >
<meta property="og:title" content="In welke gevallen is C beter?" >
<meta property="og:description" content="Taal vergeleken met C++, Java, C#, Go, Rust en Python." >
<meta property="og:image" content="https://computerworld.nl/thumbnails/400/0/a/0ab9fcaae73337e2204b61bd066bcc0c.png" >
<meta property="og:type" content="article" >
<meta property="og:url" content="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" >
<meta name="twitter:title" content="In welke gevallen is C beter?" >
<meta name="twitter:description" content="Taal vergeleken met C++, Java, C#, Go, Rust en Python." >
<meta name="twitter:image" content="https://computerworld.nl/thumbnails/400/0/a/0ab9fcaae73337e2204b61bd066bcc0c.png" >
<meta property="article:section" content="Development" >
<meta property="article:author" content="https://computerworld.nl/auteur/serdar-yegulalp" >
<meta property="article:tag" content="programmeertaal" >
<meta property="article:tag" content="programmeren" ><link href="/css/jquery-ui.min.css?r20190627170643" media="all" rel="stylesheet" type="text/css" >
<link href="https://computerworld.nl/css/computerworld.css?r20190627170643" media="all" rel="stylesheet" type="text/css" >
<link href="https://computerworld.nl/images/ico/computerworld.ico" media="screen" rel="shortcut icon" type="image/x-icon" >
<link href="https://computerworld.nl/images/ico/computerworld.png" media="screen" rel="apple-touch-icon" type="image/png" >
<link href="https://computerworld.nl/css/icons.css?r20190627170643" media="all" rel="stylesheet" type="text/css" >
<link href="//fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,300italic,700,400,300|Oxygen:300,400" media="all" rel="stylesheet" type="text/css" >
<link href="https://plus.google.com/+webwereld/" rel="publisher" >
<link href="/css/highlighting.css?r20190627170643" media="all" rel="stylesheet" type="text/css" >
<link href="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" rel="canonical" ><script>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</script><script type="text/javascript">
    //<!--
var fob = { config : { permutive : true, leadboxer : true }, meta : {}, permutive : {}, view : {} }    //-->
</script>
<script type="text/javascript">
    //<!--
fob.campaigns = { amazonWs : {} }    //-->
</script>
<script type="text/javascript" src="https://computerworld.nl/javascripts/vendor/jquery-1.8.2.min.js?r20190627170643"></script>
<script type="text/javascript" src="https://computerworld.nl/javascripts/fob-external.js?r20190627170643"></script>
<script type="text/javascript" src="https://computerworld.nl/javascripts/fob-custom.js?r20190627170643"></script>
<script type="text/javascript" src="https://computerworld.nl/javascripts/advert.js?r20190627170643"></script>
<script type="text/javascript" src="https://computerworld.nl/javascripts/sliders.js?r20190627170643"></script>
<script type="text/javascript" src="https://computerworld.nl/javascripts/jquery-documentready.js?r20190627170643"></script>
<script type="text/javascript" src="https://computerworld.nl/javascripts/async-data-functions.js?r20190627170643"></script>
<script type="text/javascript">
    //<!--
var authPlatform = 'https://idginsider.nl';    //-->
</script>
<script type="text/javascript">
    //<!--
function adRefreshProxy() {
	googletag.pubads().refresh(); 
}    //-->
</script>
<script type="text/javascript"></script>
<script type="text/javascript">
    //<!--
!function(t,e,a){a=t.createElement(e),t=t.getElementsByTagName(e)[0],a.async=1,a.src="https://spiffymachine.com/v2/0/ogqncP01NDKdcbgGSHZbkiS9eTRN1yjU2raCoZQgPCfJqz4AGus3XIWd0iWc1jsXA3mTD4F8mM63Q",t.parentNode.insertBefore(a,t)}(document,"script"),function(t,e){t[e]=t[e]||function(){(t[e].q=t[e].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,n,a){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var a=o();if(a){var r=t[e].pubads();typeof r.setTargeting===n&&r.setTargeting("admiral-engaged","true")}}a=t[e]=t[e]||{},a.cmd=a.cmd||[],typeof a.pubads===n?r():typeof a.cmd.unshift===n?a.cmd.unshift(r):a.cmd.push(r)}(window,"googletag","function");;;;!function(e,a,t,n){function r(){if(!window.frames[n]){var a=e.body;if(a){var t=e.createElement("iframe");t.style.display="none",t.name=n,a.appendChild(t)}else setTimeout(r,5)}}function c(){for(var e=[],t=0;t<arguments.length;t++)e.push(arguments[t]);s.q=s.q||[],"ping"===e[0]?e[2]({gdprAppliesGlobally:a.__cmpGdprAppliesGlobally||!1,cmpLoaded:!1},!0):e.length&&s.q.push(e)}function i(e){try{return JSON.parse(e)}catch(a){}}function o(e){if(e){var a,t="__cmpCall",n="string"==typeof e.data&&e.data.indexOf(t)>=0;a=n?(i(e.data)||{})[t]:(e.data||{})[t],a&&s(a.command,a.parameter,function(t,r){var c={__cmpReturn:{returnValue:t,success:r,callId:a.callId}};e.source.postMessage(n?JSON.stringify(c):c,"*")})}}var s=a[t];r(),"function"!=typeof s&&(s=a[t]=c,a.addEventListener?a.addEventListener("message",o,!1):a.attachEvent&&a.attachEvent("onmessage",o))}(document,window,"__cmp","__cmpLocator");    //-->
</script>
<script type="text/javascript">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</script>
<script type="text/javascript" async="async" src="//js-sec.indexww.com/ht/p/183980-129099883123366.js"></script>
<script type="text/javascript" src="/javascripts/highlight.pack.js?r20190627170643"></script>            <script>
                         
  // @PERMUTIVE (2/2)
  !function(){
    var perm = {"page":{"type":"article","audience":"enterprise","language":"nl","article":{"id":"A111162","title":"In welke gevallen is C beter?","type":"background","description":"Taal vergeleken met C++, Java, C#, Go, Rust en Python.","isInsiderContent":false,"tax":{"primaryCategories":["development"],"secondaryCategories":[]},"tags":["programmeertaal","programmeren"],"language":"nl","authors":["Serdar Yegulalp"],"source":"computerworld.nl"}}};
    var gTax = { primaryIds : [], secondaryIds : [] }
    var tax = { primaryCategories : [], secondaryCategories : [] }

    //perm.page.title=document.getElementsByTagName('title')[0].textContent;
    perm.page.description = document.head.querySelector("meta[name=description]").content;
    if (perm.page.article) {
        var a = perm.page.article;
        perm.page.keywords = a.keywords
        perm.page.tax = a.tax  || tax;
        perm.page.gTax = a.gTax || gTax;
        perm.page.tags = a.tags;
        perm.page.language = a.language; // overwrites default 'nl'
        delete a.tags;
        delete a.tax;
        delete a.gTax;
        delete a.language;
    } else {
        perm.page.keywords = [];
    }

    perm.page.ads = {
        enabled : true,
        adblocker : typeof adsAreShown == 'undefined',
    }

    fob.permutive.page = perm;

    if (fob.config.permutive) {
        !function(n,e,o,r,i){
            if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";
            for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){
            return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}
        }(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
        permutive.addon('web', perm);

        var permutiveScript = document.createElement('script');
        permutiveScript.async = true;
        permutiveScript.src = 'https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js';
        document.head.appendChild(permutiveScript);

    }

  }();
  // @/PERMUTIVE (2/2)         
            </script>
            
        
<script type="text/javascript">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</script>

<script type="text/javascript">
asyncData.default.push('getUserMessages', null);
asyncData.default.push('registerArticleView', {"articleId":111162,"isInsider":false});
$(document).ready(function(){ asyncData.default.fetch(); });</script>     <script defer="defer" src="//script.leadboxer.com/?dataset=computerworld.nl"></script>
    </head>
    <body>
   
    
    <!-- Google Tag Manager -->
    <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5LH44K" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-5LH44K');</script>
    <!-- End Google Tag Manager -->

        <div id="user-messages"></div>

        <div id="skin-wrapper">

            <div id="mpu-left">
                            </div>    
            
            
<div id="skin-left">
    <!-- Ad type 'skin-left' not rendered --></div>
<div id="skin-right">
    <!-- Ad type 'skin-right' not rendered --></div>

<script>
    function positionSkin()
    {
        var w = $(window).width();
        var forceSkin = false;
        
        var lm = 2458;
        var rm = 2458;
        
        var l = Math.floor(0 - (lm-w)/2);
        var r = Math.floor(0 - (rm-w)/2);

        var left  = $('#skin-left')[0];
        var right = $('#skin-right')[0];
       
        $(left).css({ left: l + 'px', backgroundPositionX : (-1 * l) + 'px'}).show();
        $(right).css({right: r + 'px'}).show();

        for (var i = 0; i < left.childNodes.length; i++) {
            if (!forceSkin && left.childNodes[i].nodeName.toLowerCase() === "#comment" && left.childNodes[i].nodeValue.toLowerCase() === " ad type 'skin-left' not rendered ") {
                $(left).css('display', 'none');
                return;
            }
        }

        for (var i = 0; i < right.childNodes.length; i++) {
            if (!forceSkin && right.childNodes[i].nodeName.toLowerCase() === "#comment" && right.childNodes[i].nodeValue.toLowerCase() === " ad type 'skin-right' not rendered ") {
                $(right).css('display', 'none');
                return;
            }
        }
    }
    
    $(window).resize(positionSkin);
    $(document).ready(positionSkin);
</script>

            <div id="side-menu" class="sb-slidebar sb-right sb-width-custom" data-sb-width="279px">

                <div id="side-menu-compact">
                    <div id="side-menu-compact-top-bar">
                        <span id="nav-close-button">X</span>
                        <span class="nav-headertxt">Navigatie</span>
                    </div>
                    <ul class="sidebar-menu">
                        <li class="search">
                            <form method="get" action='/zoeken'><input type="text" name="q" class="text-input" placeholder="zoeken" /><span></span><input id="search-submit" type="submit" /></form>
                        </li>
                        <li>
                            <a href="/" title="Homepage">
                                <span>Home</span>
                            </a>
                        </li>
                                            <li>
                            <a href="/topics" title="Topics">
                                <span>Topics</span>
                            </a>
                        </li>
                                                                                    <li>
                            <a href="/specials" title="Specials">
                                <span>Specials</span>
                            </a>
                        </li>
                                                                <li>
                            <a href="/state-of-it" title="State of IT">
                                <span>State of IT</span>
                            </a>
                        </li>
                                                             
                        <li>
                            <a href="/dossiers" title="Dossiers">
                                <span>Dossiers</span>
                            </a>
                        </li>  
                                         
                        <li>
                            <a rel="nofollow" href="https://jobs.computerworld.nl" title="Vacatures">
                                <span>Vacatures</span>
                            </a>
                        </li>
                    
                        <!-- mobile list -->
                                                <li class="mobile-li">
                            <a target="_blank" href="https://cio100.nl?utm_source=cw&utm_medium=cw-menu&utm_campaign=nav" title="CIO|100">
                                <span>CIO|100</span>
                            </a>
                        </li>

                                                
                        <li id="more-ict-toggler">
                            <a href="#"><span>Meer ICT</span></a>
                        </li>
                        
                        
                        
                        <li class="more-ict" id="more-webwereld">
                            <a href="//webwereld.nl">
                                <span>Webwereld</span>
                            </a>
                        </li>

                        
                        <li class="more-ict" id="more-cio">
                            <a href="//cio.nl">
                                <span>CIO</span>
                            </a>
                        </li>

                        
                        <li class="more-ict" id="more-cso">
                            <a href="//cio.nl/security">
                                <span>CSO</span>
                            </a>
                        </li>

                        
                        <li class="more-ict" id="more-cxo">
                            <a href="//cxo.nl">
                                <span>CXO</span>
                            </a>
                        </li>

                        
                        <li class="more-ict" id="more-itlibrary">
                            <a href="//itlibrary.nl">
                                <span>IT Library</span>
                            </a>
                        </li>

                        
                        <li class="more-ict" id="more-itqa">
                            <a href="//itqa.nl">
                                <span>IT Q&A</span>
                            </a>
                        </li>

                                                    
                            
                    </ul>
                </div>
            </div>
            
            <script>
                $('li.search form span').click(function(){
                    $(this).parents('form').submit();
                });
            </script>    

            <div id="max-skin-wrapper" class="body-wrapper" data-date="20190702014756">

                <!-- Header -->
                <header>

                    <!-- Top bar -->
                    <div class="wrapper-fluid" id="top-bar">
                        <div class="wrapper">
                            <ul>
                                                            <li id="tab-itqa" >
                                    <a href="//itqa.nl" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tab_itqa'});"><img src="/images/layout/itqa-logo-small.png" /></a>
                                </li>
                                                                                            <li id="tab-itlibrary" >
                                    <a href="//itlibrary.nl" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tab_itlibrary'});"><img src="/images/layout/itlibrary-logo-small.png" /></a>
                                </li>
                                                                        <li id="tab-cso">
                                            <a href="//cio.nl/security" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tab_cso'});"><img src="/images/layout/cso-logo-small.png" /></a>
                                        </li>
                                                                                            <li id="tab-cxo" >
                                    <a href="//cxo.nl" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tab_cxo'});"><img src="/images/layout/cxo-logo-small.png" /></a>
                                </li>
                                                                                            <li id="tab-cio" >
                                    <a href="//cio.nl" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tab_cio'});"><img src="/images/layout/cio-logo-small.png" /></a>
                                </li>
                                                                                            <li id="tab-computerworld"  class="active">
                                    <a href="//computerworld.nl" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tab_computerworld'});"><img src="/images/layout/computerworld-logo-small.png" /></a>
                                </li>
                                                                                            <li id="tab-webwereld" >
                                    <a href="//webwereld.nl" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tab_webwereld'});"><img src="/images/layout/webwereld-logo-small.png" /></a>
                                </li>
                                                                                        </ul>
                        </div>
                    </div>
                    <!-- End of top bar -->


                    <!-- Banner -->
                    <div class="wrapper-fluid" id="banner">
                        <div class="wrapper">
                            <div id="logo-wrapper">
                                                                
                                <a href="/" title="Computerworld is de website voor ICT-management en biedt dagelijks achtergrond artikelen, Insider artikelen, whitepapers, banen, columns en opiniestukken." onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'logo'});">
                                    <img id="logo" src="/images/layout/computerworld-logo.png" />
                                </a>
                            </div>
                            <div id="banner-wrapper">
                                <!--  DFP ad #ad_leaderboard-top -->
<div id="ad_leaderboard-top" class="leaderboard-top adsBlock">
</div>
<script type="text/javascript">
    $('#ad_leaderboard-top').responsiveAd({screenSize:'x-large xxl', scriptTags: []});
</script>
<!--  end DFP ad #ad_leaderboard-top -->
                            </div>
                        </div>
                    </div>
                    <!-- End of banner -->

                    <!--  DFP ad #ad_layer -->
<div id="ad_layer" class="layer adsBlock">
</div>
<script type="text/javascript">
    $('#ad_layer').responsiveAd({screenSize:'all', scriptTags: []});
</script>
<!--  end DFP ad #ad_layer -->

                    <!-- Navigation -->
                    <nav class="wrapper-fluid" id="main-menu">
                        <div class="wrapper">
                                                        <ul>
                                <li class="home-logo"><a href="/">&nbsp;</a></li>
                                                            <li class="menu-item hover mega dropdown" id="dropdown-topics">
                                    <a href="/topics" class="type-name" title="Topics" itemprop="url"><span>Topics</span></a>
                                    <div class="submenu">
                                        <ul class="show-preview submenu-wrapper">
                                        
                                                                                
                                            <li class="submenu-item hover">
                                                <a title="Meer Cloud" itemprop="url" href="/cloud"><span>Cloud</span></a>
                                                <ul class="preview-menu">
                                                    <li class="type-heading">
                                                        <a title="Meer Nieuws" itemprop="url" href="/cloud">Laatste artikelen over Cloud</a>
                                                    </li>
                                                    <li class="menu-article-list">
                                                        <ul>
                                                                                                                    
                                                            <li>
                                                                 <a title="Waarom Hadoop ten onder dreigt te gaan" itemprop="headline" href="https://computerworld.nl/cloud/110907-waarom-hadoop-ten-onder-dreigt-te-gaan">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/2/b/2b4dd50c612c66171223891b0010c8c0.jpg">
                                                                    <p>Waarom Hadoop ten onder dreigt te gaan</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Legacy-ellende weerhoudt bedrijven van de cloud" itemprop="headline" href="https://computerworld.nl/it-beheer/110715-legacy-ellende-weerhoudt-bedrijven-van-de-cloud">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/a/9/a963195928be4c2df888d346ead27902.jpg">
                                                                    <p>Legacy-ellende weerhoudt bedrijven van de cloud</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="ServiceNow zit boordevol ambitie" itemprop="headline" href="https://computerworld.nl/it-beheer/110733-servicenow-zit-boordevol-ambitie">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/9/3/932750d442523891e17e3d20a06b1082.jpg">
                                                                    <p>ServiceNow zit boordevol ambitie</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Consultancy wordt steeds belangrijker bij (multi-)cloudprojecten" itemprop="headline" href="https://computerworld.nl/cloud/110727-consultancy-wordt-steeds-belangrijker-bij-multi-cloudprojecten">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/f/c/fc28a7cadb6e756047b60aa6d24fd92c.jpg">
                                                                    <p>Consultancy wordt steeds belangrijker bij (multi-)cloudprojecten</p>
                                                                </a>
                                                            </li>
                                                                                                                        
                                                        </ul>
                                                    </li>
                                                </ul>
                                            </li>
                                            
                                                                                    
                                            <li class="submenu-item hover">
                                                <a title="Meer Security" itemprop="url" href="/security"><span>Security</span></a>
                                                <ul class="preview-menu">
                                                    <li class="type-heading">
                                                        <a title="Meer Nieuws" itemprop="url" href="/security">Laatste artikelen over Security</a>
                                                    </li>
                                                    <li class="menu-article-list">
                                                        <ul>
                                                                                                                    
                                                            <li>
                                                                 <a title="6 vragen voor je een ICS-monitoringstool aanschaft" itemprop="headline" href="https://computerworld.nl/security/111132-6-vragen-voor-je-een-ics-monitoringstool-aanschaft">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/f/d/fd54275c38116bd30e94d572d383d78f.jpg">
                                                                    <p>6 vragen voor je een ICS-monitoringstool aanschaft</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Incidenten escaleren bij een inbraak is behoorlijk ouderwets" itemprop="headline" href="https://computerworld.nl/security/110892-incidenten-escaleren-bij-een-inbraak-is-behoorlijk-ouderwets">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/3/6/3670e585d9debdf14a778f280415df63.jpg">
                                                                    <p>Incidenten escaleren bij een inbraak is behoorlijk ouderwets</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Heeft de AVG security verbeterd?" itemprop="headline" href="https://computerworld.nl/overheid/111003-heeft-de-avg-security-verbeterd">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/4/4/44a0e48bb371fd0880d6e3de18049471.jpg">
                                                                    <p>Heeft de AVG security verbeterd?</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="6 manieren waarop malware pc-beveiliging passeert" itemprop="headline" href="https://computerworld.nl/security/110943-6-manieren-waarop-malware-pc-beveiliging-passeert">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/4/e/4eb984fa1c90a170e56dab26063f6610.jpg">
                                                                    <p>6 manieren waarop malware pc-beveiliging passeert</p>
                                                                </a>
                                                            </li>
                                                                                                                        
                                                        </ul>
                                                    </li>
                                                </ul>
                                            </li>
                                            
                                                                                    
                                            <li class="submenu-item hover">
                                                <a title="Meer Management" itemprop="url" href="/management"><span>Management</span></a>
                                                <ul class="preview-menu">
                                                    <li class="type-heading">
                                                        <a title="Meer Nieuws" itemprop="url" href="/management">Laatste artikelen over Management</a>
                                                    </li>
                                                    <li class="menu-article-list">
                                                        <ul>
                                                                                                                    
                                                            <li>
                                                                 <a title="IT draait om meer dan de lichten laten aanhouden" itemprop="headline" href="https://computerworld.nl/it-beheer/110703-it-draait-om-meer-dan-de-lichten-laten-aanhouden">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/f/4/f494d11b496862e16134bd870d910bca.jpg">
                                                                    <p>IT draait om meer dan de lichten laten aanhouden</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Hebben de banken nog wel toekomst?" itemprop="headline" href="https://cio.nl/management/110484-hebben-de-banken-nog-wel-toekomst">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/4/e/4ea3ba919361b1e4df5ad3b176e8ac2a.jpg">
                                                                    <p>Hebben de banken nog wel toekomst?</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Wat bedrijven zoeken in een blockchainspecialist" itemprop="headline" href="https://computerworld.nl/development/110598-wat-bedrijven-zoeken-in-een-blockchainspecialist">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/0/4/04d199a534c4fa000185bbca88e155c0.png">
                                                                    <p>Wat bedrijven zoeken in een blockchainspecialist</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Technologie wordt onvoldoende ontworpen voor alle gebruikers" itemprop="headline" href="https://cio.nl/management/110466-technologie-wordt-onvoldoende-ontworpen-voor-alle-gebruikers">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/3/8/3859a7b539b230450ccc5788e683fa7a.jpg">
                                                                    <p>Technologie wordt onvoldoende ontworpen voor alle gebruikers</p>
                                                                </a>
                                                            </li>
                                                                                                                        
                                                        </ul>
                                                    </li>
                                                </ul>
                                            </li>
                                            
                                                                                    
                                            <li class="submenu-item hover">
                                                <a title="Meer Projectmanagement" itemprop="url" href="/projectmanagement"><span>Projectmanagement</span></a>
                                                <ul class="preview-menu">
                                                    <li class="type-heading">
                                                        <a title="Meer Nieuws" itemprop="url" href="/projectmanagement">Laatste artikelen over Projectmanagement</a>
                                                    </li>
                                                    <li class="menu-article-list">
                                                        <ul>
                                                                                                                    
                                                            <li>
                                                                 <a title="Hoe je strategische projecten in goede banen leidt" itemprop="headline" href="https://cio.nl/projectmanagement/103143-hoe-je-strategische-projecten-in-goede-banen-leidt">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/a/1/a13a8aaf64b88977a72b0c185b7350b6.jpg">
                                                                    <p>Hoe je strategische projecten in goede banen leidt</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="6 manieren om IT af te stemmen op de business" itemprop="headline" href="https://computerworld.nl/management/93435-6-manieren-om-it-af-te-stemmen-op-de-business">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/6/9/69232cf70517121f0d7e47c8d25e319e.jpg">
                                                                    <p>6 manieren om IT af te stemmen op de business</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="10 dingen die je over Microsoft Outlook moet weten" itemprop="headline" href="https://computerworld.nl/management/90291-10-dingen-die-je-over-microsoft-outlook-moet-weten">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/6/c/6cadb3f30440ca124eaa9d06db39e013.jpg">
                                                                    <p>10 dingen die je over Microsoft Outlook moet weten</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="14 horrorklanten - en hoe je ze neutraliseert" itemprop="headline" href="https://computerworld.nl/development/89715-14-horrorklanten---en-hoe-je-ze-neutraliseert">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/b/a/ba39227451873a2c6ff14c3c42395467.jpg">
                                                                    <p>14 horrorklanten - en hoe je ze neutraliseert</p>
                                                                </a>
                                                            </li>
                                                                                                                        
                                                        </ul>
                                                    </li>
                                                </ul>
                                            </li>
                                            
                                                                                    
                                            <li class="submenu-item hover">
                                                <a title="Meer IT Beheer" itemprop="url" href="/it-beheer"><span>IT Beheer</span></a>
                                                <ul class="preview-menu">
                                                    <li class="type-heading">
                                                        <a title="Meer Nieuws" itemprop="url" href="/it-beheer">Laatste artikelen over IT Beheer</a>
                                                    </li>
                                                    <li class="menu-article-list">
                                                        <ul>
                                                                                                                    
                                                            <li>
                                                                 <a title="Hoe breng je je moderne IT goed in kaart?" itemprop="headline" href="https://computerworld.nl/it-beheer/111090-hoe-breng-je-je-moderne-it-goed-in-kaart">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/a/b/abd090ae57deb644872cbc58f208dc94.jpg">
                                                                    <p>Hoe breng je je moderne IT goed in kaart?</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="8 tips voordat je Windows 10 versie 1903 uitrolt" itemprop="headline" href="https://computerworld.nl/it-beheer/111018-8-tips-voordat-je-windows-10-versie-1903-uitrolt">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/e/e/ee0069c087f192d1bfa4b6d0b84457cd.jpg">
                                                                    <p>8 tips voordat je Windows 10 versie 1903 uitrolt</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Hoe iOS en macOS IT'ers beter bedienen" itemprop="headline" href="https://computerworld.nl/it-beheer/110985-hoe-ios-en-macos-it-ers-beter-bedienen">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/6/4/64ef29bc21d5ef5e8414f847e176459c.jpg">
                                                                    <p>Hoe iOS en macOS IT'ers beter bedienen</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Soepel identiteitsbeheer maakt IT onzichtbaar en succesvol" itemprop="headline" href="https://computerworld.nl/security/110754-soepel-identiteitsbeheer-maakt-it-onzichtbaar-en-succesvol">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/9/2/928530155138d14141a1704089a279e1.jpg">
                                                                    <p>Soepel identiteitsbeheer maakt IT onzichtbaar en succesvol</p>
                                                                </a>
                                                            </li>
                                                                                                                        
                                                        </ul>
                                                    </li>
                                                </ul>
                                            </li>
                                            
                                                                                    
                                            <li class="submenu-item hover">
                                                <a title="Meer Carrière" itemprop="url" href="/carriere"><span>Carrière</span></a>
                                                <ul class="preview-menu">
                                                    <li class="type-heading">
                                                        <a title="Meer Nieuws" itemprop="url" href="/carriere">Laatste artikelen over Carrière</a>
                                                    </li>
                                                    <li class="menu-article-list">
                                                        <ul>
                                                                                                                    
                                                            <li>
                                                                 <a title="Met alleen mannen redden we het niet in de IT" itemprop="headline" href="https://computerworld.nl/carriere/109536-met-alleen-mannen-redden-we-het-niet-in-de-it">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/7/6/7699d8024f2ffa5e5c705d64201b5b3e.jpg">
                                                                    <p>Met alleen mannen redden we het niet in de IT</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Meer vrouwen in de IT maakt tech sterker" itemprop="headline" href="https://computerworld.nl/carriere/109524-meer-vrouwen-in-de-it-maakt-tech-sterker">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/b/3/b364a0560cb2b6640fa462ba1c55fa81.jpg">
                                                                    <p>Meer vrouwen in de IT maakt tech sterker</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Vraag naar blockchain-ontwikkelaars stijgt explosief" itemprop="headline" href="https://computerworld.nl/carriere/108278-vraag-naar-blockchain-ontwikkelaars-stijgt-explosief">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/0/4/04d199a534c4fa000185bbca88e155c0.png">
                                                                    <p>Vraag naar blockchain-ontwikkelaars stijgt explosief</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Word jij de developer van het jaar?" itemprop="headline" href="https://computerworld.nl/development/105771-word-jij-de-developer-van-het-jaar">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/7/9/795f4a393e09162a2de9c4e490fd3102.jpg">
                                                                    <p>Word jij de developer van het jaar?</p>
                                                                </a>
                                                            </li>
                                                                                                                        
                                                        </ul>
                                                    </li>
                                                </ul>
                                            </li>
                                            
                                                                                    
                                            <li class="submenu-item hover">
                                                <a title="Meer Overheid" itemprop="url" href="/overheid"><span>Overheid</span></a>
                                                <ul class="preview-menu">
                                                    <li class="type-heading">
                                                        <a title="Meer Nieuws" itemprop="url" href="/overheid">Laatste artikelen over Overheid</a>
                                                    </li>
                                                    <li class="menu-article-list">
                                                        <ul>
                                                                                                                    
                                                            <li>
                                                                 <a title="Heeft de AVG security verbeterd?" itemprop="headline" href="https://computerworld.nl/overheid/111003-heeft-de-avg-security-verbeterd">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/4/4/44a0e48bb371fd0880d6e3de18049471.jpg">
                                                                    <p>Heeft de AVG security verbeterd?</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Hoe de Pokémon Company zich aanpaste aan de AVG" itemprop="headline" href="https://computerworld.nl/algemeen/108353-hoe-de-pokemon-company-zich-aanpaste-aan-de-avg">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/7/7/773d91e616ca8a5cbf6f6939c1585371.jpg">
                                                                    <p>Hoe de Pokémon Company zich aanpaste aan de AVG</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="7 onverwachte nadelen van AVG op security" itemprop="headline" href="https://computerworld.nl/security/107906-7-onverwachte-nadelen-van-avg-op-security">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/b/0/b0da9c9a96ae267e6e5ff08dc6900616.jpg">
                                                                    <p>7 onverwachte nadelen van AVG op security</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li>
                                                                 <a title="Copyrightplan van de EU is een regelrechte internetramp" itemprop="headline" href="https://computerworld.nl/overheid/105408-copyrightplan-van-de-eu-lijkt-een-regelrechte-internetramp">
                                                                    <img alt="" src="https://computerworld.nl/thumbnails/cropped/172x100/d/a/da78a8d46bc3850249b2fab8d95c2e98.jpg">
                                                                    <p>Copyrightplan van de EU is een regelrechte internetramp</p>
                                                                </a>
                                                            </li>
                                                                                                                        
                                                        </ul>
                                                    </li>
                                                </ul>
                                            </li>
                                            
                                                                                        
                                        </ul>
                                    </div>
                                </li>
                             
                            
                                                            <li class="menu-item hover mega dropdown" id="dropdown-specials">
                                    <a href="/specials" class="type-name" title="Alle specials" itemprop="url"><span>Specials</span></a>
                                    <div class="submenu">
                                        <ul class="show-preview submenu-wrapper">
                                            <li class="submenu-item hover first">
                              
                                                <ul class="preview-menu full-width">
                                                    <li class="type-heading">
                                                        <a title="Alle specials" itemprop="url" href="/specials">Specials</a>
                                                    </li>
                                                    <li class="menu-article-list special">
                                                        <ul>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://cio.nl/campaign/workfront">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Transform Your Work" src="https://computerworld.nl/thumbnails/170x60/d/f/df2a34f767d95d7f4a730a3bae34418d.png">
                                                                   </div>
                                                                   <p>Transform Your Work</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://computerworld.nl/campaign/new-business-insights?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Ontdek nieuwe zakelijke inzichten" src="https://computerworld.nl/thumbnails/200x60/d/4/d44d669a6b1b866c144a6709c4c7868e.png">
                                                                   </div>
                                                                   <p>Ontdek nieuwe zakelijke inzichten</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://cio.nl/campaign/intelligent-informatiemanagement?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Intelligent informatiemanagement" src="https://computerworld.nl/thumbnails/200x60/9/1/915b62760a95970a9d7377c38eab3dd3.png">
                                                                   </div>
                                                                   <p>Intelligent informatiemanagement</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://cio.nl/campaign/connected-planning?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Connected Planning" src="https://computerworld.nl/thumbnails/200x60/d/b/db8e53ffc67c3f8638b6bfe4209cacb0.png">
                                                                   </div>
                                                                   <p>Connected Planning</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://computerworld.nl/campaign/customer-experience-en-datacenter-solutions?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Customer Experience" src="https://computerworld.nl/thumbnails/200x60/4/c/4c7229fa2f3b17b31c858cb1046dd2c6.png">
                                                                   </div>
                                                                   <p>Customer Experience</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="http://cio.nl/campaign/the-connected-business?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="The Connected Business" src="https://computerworld.nl/thumbnails/114x60/a/6/a65ea93a1979f3ffdb1b33fcbfdd02b5.png">
                                                                   </div>
                                                                   <p>The Connected Business</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://cio.nl/campaign/in-control-over-de-multi-cloud?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="In control over de multi-cloud" src="https://computerworld.nl/thumbnails/114x60/9/d/9db6f6dc2967b88fd11162fae6792102.png">
                                                                   </div>
                                                                   <p>In control over de multi-cloud</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="http://computerworld.nl/campaign/tour-de-france-dimension-data?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Dimension Data" src="https://computerworld.nl/thumbnails/113x60/0/8/08abaaf0f99c8c9c90577329d9fd055a.png">
                                                                   </div>
                                                                   <p>Dimension Data</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://webwereld.nl/campaign/dutch-tech-blog?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Dutch Tech Blog" src="https://computerworld.nl/thumbnails/200x60/7/8/78b6456bb217ea1a22e5102e981b5d32.png">
                                                                   </div>
                                                                   <p>Dutch Tech Blog</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://computerworld.nl/campaign/future-of-work?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Future of Work" src="https://computerworld.nl/thumbnails/200x60/a/8/a8e3823eeba0e07b49046754bacd2625.png">
                                                                   </div>
                                                                   <p>Future of Work</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="http://webwereld.nl/campaign/it-voor-het-mkb?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="IT voor het MKB" src="https://computerworld.nl/thumbnails/265x60/6/6/665be1f3bd3e9402cca6f5af492d141a.png">
                                                                   </div>
                                                                   <p>IT voor het MKB</p>
                                                                </a>
                                                            </li>
                                                                                                                    
                                                            <li class="special">
                                                                <a title="" itemprop="headline" href="https://webwereld.nl/campaign/lease-anything?utm_source=specials_overzicht&utm_medium=specials_overzicht&utm_campaign=specials_overzicht">
                                                                   <div class="menu-img-wrapper special">
                                                                    <img alt="Lease Anything" src="https://computerworld.nl/thumbnails/200x60/9/b/9b4e39daa5e2211b38a52b3dd9bc2cf7.png">
                                                                   </div>
                                                                   <p>Lease Anything</p>
                                                                </a>
                                                            </li>
                                                                                                                        <li class="more-specials">
                                                                <a title="Alle specials" itemprop="url" href="/specials">Bekijk alle specials &raquo;</a>
                                                            </li>    
                                                        </ul>
                                                    </li>
                                                </ul>
                                            </li>
                                        </ul>
                                    </div>
                                </li>
                            
                                                            <li class="menu-item hover mega">
                                    <a href="/state-of-it" class="type-name" title="State of IT" itemprop="url"><span>State of IT</span></a>
                                </li>
                            
                                                            <li class="menu-item hover mega">
                                    <a href="https://jobs.computerworld.nl" class="type-name" title="Vacatures" itemprop="url"><span>Vacatures</span></a>
                                </li>
                            
                                
                                <li class="menu-item hover">
                                    <a target="_blank" href="https://cio100.nl?utm_source=cw&utm_medium=cw-menu&utm_campaign=nav" title="CIO|100">
                                        <span class="menu-navigation-item-title">CIO|100</span>
                                    </a>
                                </li>
                                
                                                                
                            </ul>

                            <ul class="right">
                                <li id="search" class="square sb-toggle-right">
                                    <a class="search-button" href="#" title="Zoeken"><span class="icon-search"></span></a>
                                </li>
                               
                                <li class="insider dynamic">
                                    <span class="user-true">
                                        <a class="log-out" href="https://computerworld.nl/uitloggen">
                                            <span class="text">afmelden</span>
                                        </a>
                                        <a class="log-out" href="https://computerworld.nl/mijn-profiel">
                                                <span title="" class="text user-status"><img src="/images/layout/insider/logged-in.png"></span>
                                        </a>                                        
                                    </span>
                                    <span class="user-false">
                                        <a class="log-in" href="https://computerworld.nl/inloggen">
                                            <span class="insider-logo"></span>
                                            <span class="text">aanmelden</span>
                                        </a>
                                    </span>
                                </li>
                            </ul>
                        </div>
                                                
                    </nav>
                    <!-- End of navigation -->

                    <!-- Compact navigation -->
                    <nav class="wrapper-fluid" id="compact-navigation">
                        <div class="inner">
                            <div id="left">
                                <ul>
                                    <li class="side-menu-toggler square">
                                        <span id="tg-icon" class="icon-list3"></span>
                                    </li>
                                </ul>
                                <ul>
                                    <li class="left-logo">
                                        <a id="logo" href="/"></a>
                                    </li>
                                </ul>
                                <ul>
                                                                        <li>
                                        <a target="_blank" href="https://cio100.nl?utm_source=cw&utm_medium=cw-menu&utm_campaign=nav" title="CIO|100" class="primary x-item">
                                            CIO|100                                        </a>
                                    </li>
                                    
                                                                    </ul>
                            </div>
                            <div id="right">
                                <ul>
                                    <li class="compact-user-menu">
                                        <a class="log-in" href="https://computerworld.nl/inloggen">
                                            <span class="text">Aanmelden</span>
                                        </a>
                                        <a class="log-out" href="https://computerworld.nl/uitloggen">
                                            <span class="text">Afmelden</span>
                                        </a>
                                        <a class="log-out" href="https://computerworld.nl/mijn-profiel">
                                            <span title="" class="text user-status"><img src="/images/layout/insider/logged-in.png"></span>
                                        </a>
                                    </li>
                                </ul>
                            </div>
                        </div>
                       
                    </nav>
                    <!-- End of compact navigation -->

                </header>
                <!-- End of header -->

                <div id="we-re-not-angry-just-a-little-disappointed">
    <div class="message">
        Beste bezoeker,<br /><br />

        Wij zien dat u een adblocker gebruikt die ervoor zorgt dat u geen advertenties ziet op computerworld.nl. Dit vinden wij jammer, want computerworld.nl is mede dankzij deze advertenties gratis toegankelijk. Wilt u een uitzondering maken voor computerworld.nl door deze te whitelisten?    
        
        <div class="seriously">!</div>
        
    </div>
</div>
                <!-- Outer wrappers -->
<div class="content-sidebar-wrapper">
    <div class="wrapper overflow">
        <!-- Content wrapper -->

        
<!--  DFP ad #ad_billboard -->
<div id="ad_billboard" class="billboard adsBlock">
</div>
<script type="text/javascript">
    $('#ad_billboard').responsiveAd({screenSize:'large x-large xxl', scriptTags: []});
</script>
<!--  end DFP ad #ad_billboard -->
<div id="breadcrumb">
<a id="breadcrumbs-page-1" title="Home" href="/">Home</a> <span class="separator">/</span> <a id="breadcrumbs-category-8" title="Development" class="category" href="/development">Development</a> <span class="separator">/</span> In welke gevallen is C beter?</div>
        <div class="content-wrapper">

            <div class="content">
    

    
 <div class="welcome">
		<span class="emph">Welkom op computerworld.nl!</span>
		Wist u dat u met een gratis Insider-account altijd op de hoogte blijft over al het nieuws, achtergrondartikelen, opinies, interviews en events rondom IT?
		<a href="/registreren">Schrijf u nu gratis in &raquo;</a>
</div>

    <article id="article" itemscope itemtype="http://schema.org/Article">
         <meta itemscope itemprop="mainEntityOfPage" itemType="http://schema.org/WebPage" itemid="http://google.com/article"/>
         
         <div itemprop="publisher" itemscope itemtype="http://schema.org/Organization" style="display:none;">
            <div itemprop="logo" itemscope itemtype="http://schema.org/ImageObject">
                <img src="https://computerworld.nl/images/layout/computerworld-logo.png"/>
                <meta itemprop="url" content="https://computerworld.nl/images/layout/computerworld-logo.png">
            </div>
            <meta itemprop="name" content="Computerworld">
         </div>

         <div id="social-buttons-wrapper">
             <div class="article-page-skyscraper-outer-wrapper"><div class="inner"><!--  DFP ad #ad_skyscraper -->
<div id="ad_skyscraper" class="skyscraper adsBlock">
</div>
<script type="text/javascript">
    $('#ad_skyscraper').responsiveAd({screenSize:'xxl', scriptTags: []});
</script>
<!--  end DFP ad #ad_skyscraper -->
</div></div>

            <ul id="social-buttons-list">
                <li class="facebook" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                    <div class="icon">
                        <span class="icon-facebook"></span>
                    </div>
                    &nbsp;
                </li>
                <li class="linkedin" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                    <div class="icon">
                        <span class="icon-linkedin"></span>
                    </div>
                    &nbsp;
                </li>
                <li class="twitter" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                    <div class="icon">
                        <span class="icon-twitter"></span>
                    </div>
                    &nbsp;
                </li>
                <li class="google-plus" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                    <div class="icon">
                        <span class="icon-googleplus"></span>
                    </div>
                    &nbsp;
                </li>
            </ul>

                            <a id="comment-count-wrapper" href="#reacties" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'social_comments'});">
                    <span>0</span>
                    Reacties
                </a>

                <a id="briefcase-wrapper" class="briefcase-button" href="#" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'social_briefcase'});">
                    <span class="icon-briefcase"></span>
                    Bewaren
                </a>

                    </div>


        <div id="header">
            <div id="image-wrapper" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
                <img src="https://computerworld.nl/thumbnails/cropped/200x126/0/a/0ab9fcaae73337e2204b61bd066bcc0c.png" alt="Tandwielen" />
                <meta itemprop="thumbnailUrl" content="https://computerworld.nl/thumbnails/cropped/200x126/0/a/0ab9fcaae73337e2204b61bd066bcc0c.png" />
                <meta itemprop="url" content="https://computerworld.nl/thumbnails/cropped/200x126/0/a/0ab9fcaae73337e2204b61bd066bcc0c.png" alt="Tandwielen">
                <meta itemprop="width" content="200">
                <meta itemprop="height" content="126">
            </div>
            <div id="text-wrapper">
                <h1 itemprop="headline" data-id="111162">
                                In welke gevallen is C beter?</h1>
                <p class="article-summary">Taal vergeleken met C++, Java, C#, Go, Rust en Python.</p>
                <h2>Soms is [x] beter, soms ben je beter af met C. Maar in welke gevallen precies? Aan de hand van vergelijkingen met andere talen kijken we waarom programmeertaal C nog steeds heerst.</h2>
            </div>
        </div>

        <div id="header-mobile">
    
            <!--  DFP ad #ad_leaderboard-mob -->
<div id="ad_leaderboard-mob" class="leaderboard-mob adsBlock">
</div>
<script type="text/javascript">
    $('#ad_leaderboard-mob').responsiveAd({screenSize:'x-small small medium', scriptTags: []});
</script>
<!--  end DFP ad #ad_leaderboard-mob -->
  
            
            <div id="top">
                <img src="https://computerworld.nl/thumbnails/cropped/200x126/0/a/0ab9fcaae73337e2204b61bd066bcc0c.png" alt="Tandwielen" />
                <h1 itemprop="headline" data-id="111162">In welke gevallen is C beter?</h1>
                <p class="article-summary">Taal vergeleken met C++, Java, C#, Go, Rust en Python.</p>
            </div>
            <h2>Soms is [x] beter, soms ben je beter af met C. Maar in welke gevallen precies? Aan de hand van vergelijkingen met andere talen kijken we waarom programmeertaal C nog steeds heerst.</h2>
        </div>

        
        <div id="author" itemprop="author">

                        <img id="avatar" src="https://computerworld.nl/thumbnails/cropped/35x35/3/3/33b0e53ed10b443bf10b9f00d4de0917.jpg" />
            <div id="text">
                <a href="/auteur/serdar-yegulalp" title="Auteur: Serdar Yegulalp" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'author_name'});">Serdar Yegulalp</a>
            </div>
            <ul id="icons">
                
                
                            </ul>

                            <div id="label-wrapper">

                    <div id="label"><a href="/type/achtergrond" title="Achtergrond" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'type'});">Achtergrond</a></div>
                    <div id="date" itemprop="datePublished" content="2019-07-01T10:47:00+02:00">
                        1 juli 2019                    </div>
                    <div id="datemodified" itemprop="dateModified" content="2019-07-01T10:49:24+02:00" style="display:none;"></div>
                </div>
                    </div>
        
            <!-- Static social icons -->
    
    
    <div class="static-social-bar default">
        <h2 class="title">Delen</h2>
        <ul id="static-icons" class="social-share-wrapper" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-short-url="http://computerworld.nl/a/111162" data-txt="In welke gevallen is C beter?" data-img="https://computerworld.nl/uploads/v/w/vw2ptin6yzvrdcsy.png" data-summary="Taal vergeleken met C++, Java, C#, Go, Rust en Python." data-src="Computerworld" data-id="111162" data-type="article">
            <li class="facebook social-share" data-platform="facebook" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                <div class="icon">
                    <span class="icon-facebook"></span>
                </div>
                &nbsp;
            </li>
            <li class="linkedin social-share" data-platform="linkedin" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                <div class="icon">
                    <span class="icon-linkedin"></span>
                </div>
                &nbsp;
            </li>
            <li class="twitter tweet social-share" data-platform="twitter" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                <div class="icon tweet">
                    <span class="icon-twitter tweet"></span>
                </div>
                &nbsp;
            </li>
            <li class="google-plus social-share" data-platform="google-plus" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                <div class="icon">
                    <span class="icon-googleplus"></span>
                </div>
                &nbsp;
            </li>
                        <li class="static-comments">
                0 Reacties            </li>
                                    <li id="briefcase-static-wrapper" class="static-briefcase briefcase-button">
                <span class="icon-briefcase"></span>
                Bewaren
            </li>
                    </ul>
    </div>        

        
        <!-- Body van het artikel -->
        <div id="body" itemprop="articleBody">
<p>Een technologie wordt niet vijftig jaar gebruikt als er niet iets is dat het beter kan dan de rest. Dat geldt zeker voor computertechnologie. Programmeertaal C bestaat sinds 1972 en is nog steeds een van de fundamentele bouwstenen van onze door software gedomineerde wereld.</p><!--  DFP ad #ad_mpu-mob -->
<div id="ad_mpu-mob" class="mpu-mob adsBlock">
</div>
<script type="text/javascript">
    $('#ad_mpu-mob').responsiveAd({screenSize:'x-small small medium', scriptTags: []});
</script>
<!--  end DFP ad #ad_mpu-mob -->
<!--  DFP ad #ad_adv1 -->
<div id="ad_adv1" class="adv1 adsBlock">
</div>
<script type="text/javascript">
    $('#ad_adv1').responsiveAd({screenSize:'large x-large xxl', scriptTags: []});
</script>
<!--  end DFP ad #ad_adv1 -->
<!--  DFP ad #ad_in_page_video -->
<div id="ad_in_page_video" class="in_page_video adsBlock">
</div>
<script type="text/javascript">
    $('#ad_in_page_video').responsiveAd({screenSize:'large x-large xxl', scriptTags: []});
</script>
<!--  end DFP ad #ad_in_page_video -->


<p>In sommige gevallen bestaat een technologie simpelweg omdat mensen er niet aan zijn toegekomen om het te vervangen door iets beters. De laatste decennia zijn er tientallen programmeertalen verschenen, waarvan sommige expliciet bedoeld waren als opvolger van C en enkele hebben wat aandeel van C afgesnoept.</p>

<p>Het is niet moeilijk om te beargumenteren dat C vervangen kan worden. Diverse onderzoeken, software-ontwikkeltrends en programmeertalen laten zien dat iets op een betere manier kan dan hoe C het doet. Maar C blijft volharden, met vele decennia aan onderzoek en ontwikkeling om het te versterken. Wat betreft prestaties, bare-metal compatibiliteit en alomvattende aanwezigheid zijn er maar weinig alternatieven. In dit artikel vergelijken we C aan de hand van een aantal alternatieven.</p>

<h2>C versus C++</h2><p>Uiteraard wordt C het vaakst vergeleken met C++ dat, zoals de naam al doet vermoeden, is geschreven als uitgebreidere aanpak van C. De verschillen tussen de twee zijn, afhankelijk van wie je het vraagt, uitgebreid of overtollig.</p>

<p>C++ is nog steeds C-achtig in zijn syntaxis en aanpak, maar biedt enkele features die niet native in C aanwezig zijn: namespaces, templates, exceptions, automatisch geheugenbeheer, enzovoorts. Projecten die de hoogste performance eisen - databases of machine learning bijvoorbeeld - worden vaak in C++ geschreven om met de features ieder beetje mogelijke performance uit de systemen te trekken.</p>

<p>Daarbij voegt C++ veel vaker dingen toe dan C. De aankomende versie, 20, geeft nog meer elementen, zoals modules, co-routines, een synchronisatie library, en concepts. De laatste revisie van C daarentegen voegt weinig toe en legt de nadruk op het behoud van achterwaartse compatibiliteit.</p>

<p>Maar alle plussen van C++ kunnen ook minpunten zijn. Grote zelfs. Hoe meer features van C++ je gebruikt, hoe meer complexiteit je toevoegt en hoe lastiger het wordt om resultaten onder controle te houden. Ontwikkelaars die zich vastleggen op een specifiek deel van C++ kunnen de ergste valkuilen en overtolligheid vermijden. Maar sommige organisaties zijn wars van de complexiteit van C++ en het schrijven in C dwingt ontwikkelaars om in een specifieke subset te blijven. Zo mijden de ontwikkelaars van de Linux-kernel C++.</p>

<p>Het kiezen van C boven C++ kan dus een manier zijn om ervoor te zorgen dat jij - en de ontwikkelaars die de code na jou moeten onderhouden - niet hoeven te worstelen met zulke complexiteiten door minimalisme af te dwingen. Aan de andere kant heeft C++ de rijkere featureset niet voor niets en dat kan een belangrijke afweging zijn. Kortom, als minimalisme beter past bij je huidige en toekomstige projecten (en teams) dan is C de logischer keuze.</p>

<h2>C versus Java</h2><p>Al decennia is Java een veelgebruikte taal voor de ontwikkeling van (zakelijke) software. De belangrijkste enterprise softwareprojecten zijn in Java geschreven, inclusief een grote meerderheid van projecten van de Apache Software Foundation. Java blijft een belangrijke taal voor de ontwikkeling bij nieuwe projecten met zakelijke requirements.</p>

<p>De syntaxis van Java leent veel van C en C++. Maar in tegenstelling tot C compileert Java niet standaard naar native code. In plaats daarvan compileert de Java runtime environment de Java-code just-in-time (JIT) om in de doelomgeving te draaien. JIT Java-code kan de prestaties van C benaderen of zelfs overtreffen.</p>

<p>De filosofie van 'write once, run anywhere' achter Java zorgt ervoor dat er voor Java-programma's weinig aan de onderliggende architectuur hoeft te worden veranderd, in tegenstelling tot C. C is wel geport naar een heleboel architecturen, maar voor C-programma's moet je nog steeds aanpassingen doen naar gelang je bijvoorbeeld op Windows of Linux gaat draaien. Die combinatie van portabiliteit en sterke prestaties, tezamen met een enorm ecosysteem aan library's en frameworks, make Java een voor de hand liggende taal en runtime voor zakelijke applicaties.</p>

<p>Waar Java onderdoet voor C is een gebied waar het nooit de bedoeling is geweest dat Java concurreert: dicht op de hardware zitten. C-code wordt gecompileerd naar machinetaal, die direct wordt verwerkt. Java wordt gecompileerd naar bytecode, wat tussenliggende code is die de Java Virtual Machine interpreteert en vertaalt naar machinetaal. Daarbij is het geheugenbeheer van C - hoewel de automatische geheugensanering van Java soms een uitkomst is - beter geoptimaliseerd voor programma's die met beperkte geheugenresources aan de slag gaan.</p>

<p>Dat gezegd hebbende, is er een aantal gebieden waar Java in de buurt komt van C qua snelheid. Je JIT-engine van de JVM optimaliseert routines op runtime gebaseerd op het gedrag van een programma, waardoor er een hoop optimalisaties mogelijk zijn die niet kunnen bij ahead-of-time compilatie van C. En hoewel de Java-runtime geheugensanering automatiseert kunnen enkele nieuwere applicaties daar omheen werken. Zo optimaliseert Apache Spark in-memory verwerking deels door eigen geheugenbeheercode te gebruiken die de JVM omzeilt.</p>

<h2>C versus C# en .Net</h2><p>Bijna twintig jaar na hun introductie zijn C# en het .Net Framework belangrijke onderdelen van de zakelijke softwarewereld. De twee zouden Microsofts antwoord op Java zijn: een beheerd compilersysteem en universele runtime. Veel van de zaken die we net noemden toen we C met Java vergeleken zijn ook waar voor C en C#/.Net.</p>

<p>Net als Java (en in zekere zin Python, waar we straks nog op terugkomen) beidt .Net portabiliteit tussen verschillende platforms en een rijk ecosysteem aan geïntegreerde software. Dat zijn geen kleine dingen, als je bekijkt hoeveel enterprise-level ontwikkeling in een .Net-wereld plaatsvindt. Als je een programma ontwikkelt in C#, of elke andere .Net-taal, kun je een universum aan tools en library's gebruiken die zijn geschreven voor de .Net-runtime.</p>

<p>Nog een Java-achtig voordeel van .Net is JIT-optimalisatie. C# en .Net-programma's kunnen ahead-of-time worden gecompileerd zoals C, maar ze worden hoofdzakelijk just-in-time gecompileerd door de .Net-runtime en geoptimaliseerd met runtime-informatie. JIT-compilatie zorgt ervoor dat er allerlei optimalisaties kunnen worden uitgevoerd voor een draaiend .Net-programma die niet kunnen worden uitgevoerd in C.</p>

<p>Net als C, leveren C# en .Net verschillende mechanismes om geheugen direct aan te spreken. Heap-, stack- en onbeheerd systeemgeheugen zijn allemaal te benaderen via .Net-API's en -objecten. Ontwikkelaars kunnen de unsafe-modus in .Net gebruiken om zelfs grotere performance te behalen.</p>

<p>Dit heeft wel een prijs. Beheerde objecten en unsafe objecten kunnen niet arbitrair worden uitgewisseld en schakelen tussen de twee gaat ten koste van de prestaties. Dat betekent dat als de prestaties van de .Net-applicaties moeten worden gemaximaliseerd, met het schakelen tussen beheerde en onbeheerde objecten tot een minimum moet beperken. Als je die prestatiekosten niet kunt gebruiken of als de .Net-runtime een slechte keuze is voor de doelomgeving (laten we zeggen, kernelruimte), of zelfs helemaal niet beschikbaar is, dan heb je C nodig. In tegenstelling tot de twee van Microsoft, heb je standaard direct geheugenbeheer in C.</p>

<h2>C versus Go</h2><p>Go-syntaxis heeft veel te danken aan C: accolades als start- of begrenzende tekens, statements die worden afgesloten met puntkomma's, enzovoorts. Ontwikkelaars die bedreven zijn in C kunnen in de regel zonder al te veel moeite overstappen op Go, zelfs met die aanvullende features als namespaces en pakketbeheer.</p>

<p>Een van de ontwerpdoelen van Go was leesbare code: zorg ervoor dat ontwikkelaars een Go-project snel kunnen bekijken en vlot de codebase leren kennen. Het grokken va C-codebases kan lastig zijn, omdat ze een optische warboel kunnen zijn van macro's en #ifdefs die specifiek voor een bepaald project en team zijn. De syntaxis van Go, en de ingebouwde codeformaten en projectmanagementtools zijn bedoeld om dat soort geïnstitutionaliseerde complexiteiten te beperken.</p>

<p>Go heeft ook features als goroutines en channels, ingebouwde tools voor concurrency en berichten tussen componenten. Bij C zou je dit zelf moeten regelen of via een externe library moeten aanspreken, maar bij Go zit dit erin verwerkt, zodat het stukken eenvoudiger is om software te bouwen dat hier gebruik van maakt.</p>

<p>Maar waar Go het meest verschilt van C is bij het geheugenbeheer. Go-objecten worden standaard automatisch beheerd en gesaneerd. Voor de meeste programmeertaken is dit ontzettend handig. Het betekent echter ook dat het lastiger is om een programma te schrijven dat geheugen op een deterministische wijze beheert.</p>

<p>Er is ook een unsafe-package meegeleverd om om te gaan met Go's types op een veilige manier, zoals willekeurig geheugen lezen en schrijven met een Go Pointer. Unsafe gebruikt daarvoor een waarschuwing dat programma's die hiermee worden geschreven niet onder de Go 1-compatibiliteit richtlijnen vallen en wellicht niet meer zo portable zijn.</p>

<p>Go is erg geschikt voor het bouwen van zaken als CLI-utilities en netwerkservices, omdat deze zelden zulke fijnmazigheid vereisen. Voor programmeerwerk als low-level stuurprogramma's, componenten van het OS op kernelniveau en andere taken die strakke controle over het geheugen eisen, ben je beter af met C.</p>

<h2>C versus Rust</h2><p>Rust is vooral een reactie op de geheugenbeheerissues die je hebt met C en C++, alsmede enkele andere tekortkomingen van de taal voor bepaalde doeleinden. Rust compileert naar native machinetaal, waardoor het qua prestaties overeenkomt met C. Maar geheugenveiligheid is de primaire aantrekkingskracht van Rust.</p>

<p>De syntaxis en compilatieregels helpen ontwikkelaars om veelvoorkomende geheugenblunders te vermijden. Als een programma een geheugenissue heeft dat botst met de syntaxis van Rust dan compileert het simpelweg niet. Nieuwkomers, vooral programmeurs die kennis hebben van een taal als C die ruimte laat voor dergelijke bugs, zijn in de eerste fase van het leren van Rust vooral bezig met het ontdekken hoe je de compiler tevreden houdt. Voorstanders van Rust vinden dat deze ellende in het begin een langetermijnvoordeel heeft: veilige code die ondanks dat wel presteert.</p>

<p>Ook heeft Rust betere tooling. Project- en componentbeheer zijn deel van de standaardtoolchain, net als bij Go. Er is een standaardmanier om packages te beheren, projectmappen te organiseren en veel andere dingen te doen die ad-hoc gebeuren in C.</p>

<p>Maar wat door voorstanders als voordelen worden gezien, kan wel eens als het tegenovergestelde worden ervaren door een C-ontwikkelaar. De safety-features van Rust bij het compileren kunnen niet worden uitgeschakeld, dus zelfs het simpelste programmaatje moet voldoen aan de strikte geheugenregels van Rust. C is in zijn standaard minder geheugenveilig, maar is wel stukken flexibeler en vergevingsgezinder.</p>

<p>Nog een mogelijk nadeel is de grootte van de Rust-taal. C heeft relatief weinig features, zelfs als je de standaardlibrary meeweegt. De featureset van Rust is groot en blijft groeien. Net als met C++ betekent meer features meer kracht, maar ook meer complexiteit. C is een kleinere taal, maar daardoor ook makkelijker te ontwerpen in je hoofd en daardoor beter geschikt voor projecten waar Rust overkill voor zou zijn.</p>

<h2>C versus Python</h2><p>Als je het vandaag de dag over software-ontwikkeling hebt, gaat het vroeger of later over Python. De taal is immers "de een na beste keus voor alles" en ook zonder twijfel een van de meest veelzijdige, met duizenden third party-libraries.</p>

<p>Wat Python benadrukt, en waar de taal het meest verschilt van C, is het bevoordelen van ontwikkelsnelheid boven uitvoeringssnelheid. Een programma dat je een uur zou kosten om te schrijven in een andere taal - zoals C - kun je in enkele minuten samenstellen in Python. Aan de andere kant kost dat programma enkele seconden om uitgevoerd te worden in C, maar een minuut in Python. (Vuistregel: Python-programma's draaien in de regel een orde van grootte langzamer dan een equivalent in C.) Maar voor veel taken op moderne hardware is Python snel genoeg. Dat is een factor in waarom het zo groot is geworden.</p>

<p>Nog een groot verschil is geheugenbeheer. In Python regelt de runtime dit allemaal waardoor ontwikkelaars zich niet druk hoeven te maken over de ins en outs van het vrijmaken en toewijzen van geheugenruimte. Maar ook hier geldt dat het gebruiksgemak ten koste gaat van prestaties van de runtime. Als je schrijft in C moet je geheugen nauwlettend in de gaten houden, maar een goed ontworpen programma in C is de gouden standaard voor machinesnelheid.</p>

<p>Onder de motorkap hebben de twee talen een diepe band: de Python-runtime is namelijk geschreven in C. Hierdoor kan Python library's die in C en C++ zijn geschreven gebruiken. Belangrijke delen van het Python-exosysteem aan third party-library's, zoals die voor machine learning, zijn in hun kern C.</p>

<p>Kortom: als ontwikkelsnelheid belangrijker is dan uitvoeringssnelheid, en als de meeste delen kunnen worden geïsoleerd in componenten in plaats van verspreid te worden door de hele code, dan is Python of een mix van Python met C-library's een betere keuze dan C. In alle andere gevallen, is C nog altijd het beste.</p>

</p><div id="article-scroll-bottom"></div>
            <!--  DFP ad #ad_video-intelligence -->
<div id="ad_video-intelligence" class="video-intelligence adsBlock">
</div>
<script type="text/javascript">
    $('#ad_video-intelligence').responsiveAd({screenSize:'large x-large xxl', scriptTags: []});
</script>
<!--  end DFP ad #ad_video-intelligence -->
    
    </div>
    
    <script>
        $('#article p').each(function(){
            if($(this).html().length < 1) { $(this).remove(); }
        });     
        
        var shortUrl = 'http://computerworld.nl/a/111162';
        
        $('#article .streamer').each(function(){
            var content = '';
            
            if ($(this).find('p').length) {
                $(this).find('p').each(function(){
                    content += $(this).html();
                });
            } else {
                content = $(this).html();
            }
            
                        if (content.length > 117) {
                content = content.substring(0, 113) + ' ...';
            }
            
            $(this).append('<a href="https://twitter.com/intent/tweet?text=' + encodeURIComponent(content) + '&url=' + encodeURIComponent(shortUrl) +'" class="tweet-this twitter-share-button" data-text="' + $('<div />').text(content).html() + '" data-url="' + shortUrl + '"><span class="bird"></span>Tweet dit</span>');
        });
        
        $('a.tweet-this').click(function(e) {
            e.preventDefault();
            var url = $(this).attr('href');
            if (!window.open(url, 'tweet', 'width=600,height=400')) {
                document.location = url;
            }
        });
        
                
    </script>

    
    <div class="block block-latest-questions block-static block-sidebar">
        <h3 class="title">Gerelateerde vragen</h3>    <div class="content">
        <ul class="itqa-list">
                <li>
                    <div class="question">
                        <a href="https://itqa.nl/software/waarom-geen-cobol-genoemd-nog-altijd-de-grootste-als-het-gaat-om-financiele-transacties-en-het-woord-legacy-is-vooral-geldklopperij-wat-dacht-je-van-roi-als-je-30-jaar-dezelfde-code-gebruikt-6225" title="Waarom geen COBOL genoemd? Nog altijd de grootste als het gaat om financiële transacties. En het woord legacy is vooral geldklopperij. Wat dacht je van ROI als je 30 jaar dezelfde code gebruikt?" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'question_1_title'});">Waarom geen COBOL genoemd? Nog altijd de grootste als het gaat om financiële transacties. En het woord legacy is vooral geldklopperij. Wat dacht &hellip;</a>
                    </div>
                    <div class="answer-counter">
                                            </div>
                </li>
                    <li>
                    <div class="question">
                        <a href="https://itqa.nl/algemeen/welke-tool-kan-ik-het-beste-gebruiken-voor-het-programmeren-van-blockchain-6177" title="Welke tool kan ik het beste gebruiken voor het programmeren van blockchain?" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'question_2_title'});">Welke tool kan ik het beste gebruiken voor het programmeren van blockchain?</a>
                    </div>
                    <div class="answer-counter">
                        <a href="https://itqa.nl/algemeen/welke-tool-kan-ik-het-beste-gebruiken-voor-het-programmeren-van-blockchain-6177" title="Welke tool kan ik het beste gebruiken voor het programmeren van blockchain?" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'question_2_answers'});">1</a>                    </div>
                </li>
                    <li>
                    <div class="question">
                        <a href="https://itqa.nl/algemeen/is-een-license-key-voldoende-om-bij-repair-reimage-in-te-loggen-3087" title="Is een license key voldoende om bij Repair Reimage in te loggen?" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'question_3_title'});">Is een license key voldoende om bij Repair Reimage in te loggen?</a>
                    </div>
                    <div class="answer-counter">
                        <a href="https://itqa.nl/algemeen/is-een-license-key-voldoende-om-bij-repair-reimage-in-te-loggen-3087" title="Is een license key voldoende om bij Repair Reimage in te loggen?" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'question_3_answers'});">1</a>                    </div>
                </li>
            </ul>
        
        <div class="itqa-sidebar-form-wrapper">
            <form method="get" action="https://itqa.nl/stel-een-vraag">
                <div class="question-ask-wrapper">
                                        <input type="text" name="question" id="question" placeholder="Stel je vraag" />
                </div>
                <div class="question-ask-button-wrapper">
                    <button class="submit">Stel je vraag</button>
                </div>
                
			      
			   
			   <script src="/javascripts/jquery-ui.min.js"></script>
			   
			   <script>
			   $('#question').autocomplete({
				  source: '/itqa/question/search',
				  minLength: 2
				});
				
				$(document).on('click', '.ui-menu-item', function(e){
					e.preventDefault();
					$('form input').prop('disabled', true);
					getAsyncDataFetcher().get({'redirectToQuestion' : $(this).html()});
				});
				</script>                   
                
            </form>
        </div>
        
               
    </div>
    <div class="footer">
        <a href="//itqa.nl" class="">Meer vragen &raquo;</a>    </div>
</div>

    
        <div id="article-scripts">
                    </div>

            <!-- Static social icons -->
    
    
    <div class="static-social-bar bottom">
        <h2 class="title">Delen</h2>
        <ul id="static-icons" class="social-share-wrapper" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-short-url="http://computerworld.nl/a/111162" data-txt="In welke gevallen is C beter?" data-img="https://computerworld.nl/uploads/v/w/vw2ptin6yzvrdcsy.png" data-summary="Taal vergeleken met C++, Java, C#, Go, Rust en Python." data-src="Computerworld" data-id="111162" data-type="article">
            <li class="facebook social-share" data-platform="facebook" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                <div class="icon">
                    <span class="icon-facebook"></span>
                </div>
                &nbsp;
            </li>
            <li class="linkedin social-share" data-platform="linkedin" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                <div class="icon">
                    <span class="icon-linkedin"></span>
                </div>
                &nbsp;
            </li>
            <li class="twitter tweet social-share" data-platform="twitter" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                <div class="icon tweet">
                    <span class="icon-twitter tweet"></span>
                </div>
                &nbsp;
            </li>
            <li class="google-plus social-share" data-platform="google-plus" data-url="https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter" data-text="In welke gevallen is C beter?">
                <div class="icon">
                    <span class="icon-googleplus"></span>
                </div>
                &nbsp;
            </li>
                        <li class="static-comments">
                0 Reacties            </li>
                                    <li id="briefcase-static-wrapper" class="static-briefcase briefcase-button">
                <span class="icon-briefcase"></span>
                Bewaren
            </li>
                    </ul>
    </div>  
               
        <script>
                /*fob.meta.currentObject = { type : 'article', id : 111162 }
                getAsyncDataFetcher().get({ getTweetCount : fob.meta.currentObject });
                updateGooglePlusCounter('https://computerworld.nl/development/111162-in-welke-gevallen-is-c-beter')*/
        </script>

        <!-- Lees meer blok -->
            <div id="tags">
                <h2 class="title">Lees meer over</h2>
                <ul id="tag-list">
            <li>
                <a href="/tag-programmeertaal" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tag_1'});">
                    programmeertaal                </a>
            </li>
            <li>
                <a href="/tag-programmeren" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'tag_2'});">
                    programmeren                </a>
            </li>
                </ul>
            </div>

        

    </article>

    <div id="article-bottom"></div> 
    <!-- End of article -->

<div id="article-page-skyscraper-wrapper">
    <!--  DFP ad #ad_skyscraper -->
<div id="ad_skyscraper" class="skyscraper adsBlock">
</div>
<script type="text/javascript">
    $('#ad_skyscraper').responsiveAd({screenSize:'xxl', scriptTags: []});
</script>
<!--  end DFP ad #ad_skyscraper -->
</div>

                    <div><script type="text/javascript" src="https://a-ssl.ligatus.com/?ids=103776&t=js&s=1"></script></div>

        
    <!-- Comments -->
    <div id="article-comments-wrapper" class="page-block">

        


<div id="article-comments" class="page-block">
    <h4 class="title" >
        <a id="toggle-comment-sort-order-button" href="#">Oudste boven &#x25BE;</a>
        Reacties
    </h4>
        <a name="reacties"></a> <!-- Used as anchor in URL, also therefore it's in Dutch -->
        <div id="comments-wrapper">

                        <ul id="comments-main-list">                    <!-- Will be moved by jQuery -->
                    <li class="comment-reply-form-wrapper comment-small-form-wrapper" data-comment-id="0">
                        <h4>Reageren</h4>
                        <form>
                            <textarea></textarea>
                            <input type="submit" value="Plaats reactie" />
                            <button type="reset">Annuleren</button>
                        </form>
                    </li>

                    <li class="comment-edit-form-wrapper comment-small-form-wrapper" data-comment-id="0">
                        <form>
                            <h4>Reactie bewerken</h4>
                            <textarea></textarea>
                            <input type="submit" value="Opslaan" />
                            <button type="reset">Annuleren</button>
                        </form>
                    </li>

                    <li class="comment-abuse-form-wrapper comment-small-form-wrapper" data-comment-id="0">
                        <form>
                            <h4>Misbruik melden</h4>
                            <textarea></textarea>
                            <input type="submit" value="Melden" />
                            <button type="reset">Annuleren</button>
                        </form>
                    </li>
                </ul>
                                <span class="comment-no-comments">Er zijn nog geen reacties.</span>
                            <div class="comment-post-form-wrapper">
                <h4>Reageer</h4>
                <form>
                    <textarea></textarea>
                    <input type="submit" value="Plaats reactie" />
                </form>
            </div>

            <div class="comment-post-form-wrapper-placeholder">
                Om een reactie te plaatsen moet u <a href="https://computerworld.nl/inloggen" class="">ingelogd</a> zijn.
            </div>

                        <div class="comment-preview">
                <h3>Preview</h3>
                <div class="comment-body">
                </div>
            </div>
        </div>
</div>


<script type="text/javascript">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</script>

    </div>
    <!-- End of comments -->
            </div>
        </div>
        <!-- End of content wrapper -->

        <!-- Sidebar wrapper -->
        <section id="sidebar">
            <!--  DFP ad #ad_mpu -->
<div id="ad_mpu" class="mpu adsBlock">
</div>
<script type="text/javascript">
    $('#ad_mpu').responsiveAd({screenSize:'large x-large xxl', scriptTags: []});
    googletag.cmd.push(function(){
        if (typeof(IDGdfpAds['ad_mpu'])!='undefined')
        {
            setInterval(function() {
                googletag.pubads().clear([IDGdfpAds['ad_mpu']]);
                googletag.pubads().refresh([IDGdfpAds['ad_mpu']]);
            }, 300000);
        }
    });
</script>
<!--  end DFP ad #ad_mpu -->
    <div class="block block-jobs block-static block-sidebar">
        <h3 class="title">ICT-vacatures van Stepstone</h3>    <div class="content" class="stepstone-job-box">
        <ul>
                    <li class="job">
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-job','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2F20e8d8e32009648b6bcbee4d21d65530" target="_blank" title="Testanalist IT op de trein - Utrecht" class="job-title">Testanalist IT op de trein - Utrecht</a>
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-company','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2F20e8d8e32009648b6bcbee4d21d65530" target="_blank" title="NS" class="job-more">NS</a>
            </li>
                    <li class="job">
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-job','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2F8183bd24776295b0a8f2b154f683ee71" target="_blank" title="Senior PHP Developer" class="job-title">Senior PHP Developer</a>
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-company','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2F8183bd24776295b0a8f2b154f683ee71" target="_blank" title="VONQ" class="job-more">VONQ</a>
            </li>
                    <li class="job">
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-job','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2Fee6a5e380e0ff774ed9c5b6f50018fd3" target="_blank" title="UX Designer" class="job-title">UX Designer</a>
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-company','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2Fee6a5e380e0ff774ed9c5b6f50018fd3" target="_blank" title="Fontem Ventures B.V." class="job-more">Fontem Ventures B.V.</a>
            </li>
                    <li class="job">
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-job','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2F4d09651a6341e2eff916807cc8c368e3" target="_blank" title="Information Analyst Color" class="job-title">Information Analyst Color</a>
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-company','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2F4d09651a6341e2eff916807cc8c368e3" target="_blank" title="AkzoNobel" class="job-more">AkzoNobel</a>
            </li>
                    <li class="job">
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-job','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2F558ac882f4b1acc447f8e559e8364be9" target="_blank" title="Werken bij SD Worx: Consultant X-Tend" class="job-title">Werken bij SD Worx: Consultant X-Tend</a>
                <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-company','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=http%3A%2F%2Fwebwereld.nl%2Fvacatures%2F558ac882f4b1acc447f8e559e8364be9" target="_blank" title="Jobs via StepStone.be" class="job-more">Jobs via StepStone.be</a>
            </li>
                </ul>
  <a onclick="ga('send', {'hitType':'event','eventAction':'click','eventLabel':'Stepstone-sidebar-more','eventCategory':'jobs'});" href="/page/stepstone-redirect?url=https%3A%2F%2Fjobs.computerworld.nl" target="_blank" title="Bekijk alle ICT vacatures &raquo;" class="job-external">Bekijk alle ICT vacatures &raquo;</a>        
    </div>
</div>     <div class="block block-related-articles block-static block-sidebar">
        <h3 class="title">Gerelateerde artikelen</h3>    <div class="content">
        <ul>
            <li>
                <div class="image-wrapper">
                    <a href="https://computerworld.nl/development/111042-9-duistere-geheimen-van-low-code" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-1'});">
                        <img src="https://computerworld.nl/uploads/e/e/eeoj1ztxr0dfm307.jpg" />
                    </a>
                </div>
                <div class="text-wrapper">
                    <h3><a href="https://computerworld.nl/development/111042-9-duistere-geheimen-van-low-code" title="9 duistere geheimen van low-code" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-1'});">9 duistere geheimen van low-code</a></h3>
                </div>
            </li>
            <li>
                <div class="image-wrapper">
                    <a href="https://webwereld.nl/development/110877-groeiend-python-populairder-dan-ooit" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-2'});">
                        <img src="https://computerworld.nl/uploads/4/5/45mv9hdh5tsz3kts.jpg" />
                    </a>
                </div>
                <div class="text-wrapper">
                    <h3><a href="https://webwereld.nl/development/110877-groeiend-python-populairder-dan-ooit" title="Groeiend Python populairder dan ooit" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-2'});">Groeiend Python populairder dan ooit</a></h3>
                </div>
            </li>
            <li>
                <div class="image-wrapper">
                    <a href="https://computerworld.nl/development/110682-10-beste-tools-voor-het-programmeren-van-blockchains" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-3'});">
                        <img src="https://computerworld.nl/uploads/5/d/5d4s0ufis7tpogrf.jpg" />
                    </a>
                </div>
                <div class="text-wrapper">
                    <h3><a href="https://computerworld.nl/development/110682-10-beste-tools-voor-het-programmeren-van-blockchains" title="10 beste tools voor het programmeren van blockchains" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-3'});">10 beste tools voor het programmeren van blockchains</a></h3>
                </div>
            </li>
            <li>
                <div class="image-wrapper">
                    <a href="https://computerworld.nl/development/110598-wat-bedrijven-zoeken-in-een-blockchainspecialist" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-4'});">
                        <img src="https://computerworld.nl/uploads/8/d/8d2sqr6mit5kh4vf.png" />
                    </a>
                </div>
                <div class="text-wrapper">
                    <h3><a href="https://computerworld.nl/development/110598-wat-bedrijven-zoeken-in-een-blockchainspecialist" title="Wat bedrijven zoeken in een blockchainspecialist" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-4'});">Wat bedrijven zoeken in een blockchainspecialist</a></h3>
                </div>
            </li>
            <li>
                <div class="image-wrapper">
                    <a href="http://computerworld.nl/development/109989-10-overwegingen-bij-het-kiezen-van-een-high-productivity-platform" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-5'});">
                        <img src="https://computerworld.nl/uploads/0/4/04qxmce44d1h7ced.jpg" />
                    </a>
                </div>
                <div class="text-wrapper">
                    <h3><a href="http://computerworld.nl/development/109989-10-overwegingen-bij-het-kiezen-van-een-high-productivity-platform" title="10 overwegingen bij het kiezen van een high-productivity platform" onclick="ga('send', {'hitType':'event','eventCategory':'relatedArticle','eventAction':'click','eventLabel':'relatedArticle-5'});">10 overwegingen bij het kiezen van een high-productivity platform</a></h3>
                </div>
            </li>
        </ul>
    </div>
</div>
        </section>
        <!-- End of sidebar wrapper -->

    </div>
    
</div>
<div id="recommended-wrapper">
    <div class="inner">
        <div id="close-recommended">
            <span class="icon-close"></span>
        </div>
        <div id="title">Aanbevolen artikel</div>
        <div id="image-wrapper">
            <a href="https://computerworld.nl/software/94833-10-windows-10-instellingen-voor-paranoide-gebruikers" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'recommendedArticle_image'});" title="10 Windows 10-instellingen voor paranoïde gebruikers"><img src="https://computerworld.nl/thumbnails/cropped/120x68/7/5/75a0a64ed9219ad17698330b41627aa1.jpg" /></a>
        </div>
        <div id="text-wrapper">
            <a href="https://computerworld.nl/software/94833-10-windows-10-instellingen-voor-paranoide-gebruikers" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'recommendedArticle_title'});" title="10 Windows 10-instellingen voor paranoïde gebruikers">10 Windows 10-instellingen voor paranoïde gebruikers</a>
        </div>
    </div>
</div>

<div id="fb-root"></div>

<script>

var stickySidebar = true;
    
$(document).ready(function(){

    //Syntax highlighting
    $('#article pre').each(function(i, block) {
        hljs.highlightBlock(block);
    })

    // -------------------------------------------------------------------------------------------------------------------------
    // Briefcase
    // -------------------------------------------------------------------------------------------------------------------------

   // When someone clicks on the briefcase
    $('.briefcase-button').click(function(e) {

        // Stop the anchor from redirecting
        e.preventDefault();

        // Grab the article's ID
        var articleId = 111162;

        // Post to the API
        getAsyncDataFetcher().post({'saveArticleToBriefcase': articleId });

    });


    // -------------------------------------------------------------------------------------------------------------------------
    // recommended
    // -------------------------------------------------------------------------------------------------------------------------

    // Determine the anchor point of when the animation kicks in
    var anchorPoint = $('#article').offset().top + $('#article').height() - $(window).height();

    $(window).scroll(function(){
        // If the user has scrolled past the anchor point
        if( $(window).scrollTop() >= anchorPoint )
        {
            // Animate the recommended block in (slide from right to left)
            //TMP recommended article// $('#recommended-wrapper').stop().animate({'right': '20px'});
        }
        // If the user is scrolling back to the top (or has not reached the anchor point yet)
        else
        {
            // If the block is currently visible
            if( $('#recommended-wrapper').css('right') === '20px' )
            {
                // Stop current animation (if any) and animate it back out of view
                //TMP recommended article// $("#recommended-wrapper").stop().animate({'right': '-380px'});
            }
        }
    });

    $('#close-recommended').click(function(){
        $('#recommended-wrapper').slideUp('fast');
        $('#recommended-wrapper').animate({'right': '-380px'});
    });

});

    // Social buttons sticky
    function moveSocialButtons()
    {
        var $socialButtonWrapper = $('#social-buttons-wrapper');
        var scrollTop = $(window).scrollTop();
        var articleTop = $('article').offset().top;
        var footerTop = $('#article-bottom').offset().top;

        if (scrollTop > articleTop - 10) {
            if (scrollTop + $socialButtonWrapper.height() < footerTop) {
                 $socialButtonWrapper.css('top', ((scrollTop + 50) - articleTop) + 'px');
            } else {
                $socialButtonWrapper.css('top', ((scrollTop + 50 - ((footerTop) - $socialButtonWrapper.height())) - articleTop) + 'px');
            }
        } else {
            $socialButtonWrapper.css('top', 0);
        }
    }

    $(document).on('scroll', window, moveSocialButtons);
    $(moveSocialButtons);
    

    
</script>

<script type="text/javascript" src="/javascripts/social-buttons.js"></script>



<script>

// Facebook Pixel Code
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');
fbq('init', '107218526611596'); // Insert your pixel ID here.

fbq('trackCustom', 'article-read', {
    id     :  111162,
    tag    : 'development',
    domain : window.location.host,
});

// End Facebook Pixel Code

</script>

        <script src="https://s.skimresources.com/js/122201X1593560.skimlinks.js"></script>        
                

                <!-- Footer -->
                <footer class="wrapper-fluid">
                    
            
                    
                    <div class="inner">
                        
              <div id="bottom-billboard-wrapper"><div><!--  DFP ad #ad_billboard-bottom -->
<div id="ad_billboard-bottom" class="billboard-bottom adsBlock">
</div>
<script type="text/javascript">
    $('#ad_billboard-bottom').responsiveAd({screenSize:'large x-large xxl', scriptTags: []});
</script>
<!--  end DFP ad #ad_billboard-bottom -->
</div></div>                                
                        
                        <div id="sub-footer-wrapper">

                            <ul id="sub-footer">
                                <li id="sub-footer-contact"><a href="/contact">Contact</a></li>
                                <li id="sub-footer-disclaimer"><a href="/disclaimer">Disclaimer</a></li>
                                <li id="sub-footer-advertize"><a href="/adverteren">Adverteren</a></li>
                                <li id="sub-footer-sitemap"><a href="/sitemap">Sitemap</a></li>
                            </ul>
                        </div>
                        <ul id="footer-list">
                            <li id="footer-logo-webwereld">
                                <a href="//webwereld.nl" title="Webwereld" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'footer_logo_webwereld'});">
                                    <span class="image-wrapper"><img class="logo" src="/images/layout/footer/webwereld.png" alt="" /></span>
                                    <span class="text-wrapper">Nieuws</span>
                                </a>
                            </li>
                            <li id="footer-logo-computerworld" class="active">
                                <a href="//computerworld.nl" title="Computerworld" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'footer_logo_computerworld'});">
                                    <span class="image-wrapper"><img class="logo" src="/images/layout/footer/computerworld.png" alt="" /></span>
                                    <span class="text-wrapper">Achtergrond</span>
                                </a>
                            </li>
                            <li id="footer-logo-cio">
                                <a href="//cio.nl" title="CIO" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'footer_logo_cio'});">
                                    <span class="image-wrapper"><img class="logo" src="/images/layout/footer/cio.png" alt="" /></span>
                                    <span class="text-wrapper">Strategie</span>
                                </a>
                            </li>
                            <li id="footer-logo-cxo">
                                <a href="//cxo.nl" title="CXO" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'footer_logo_cxo'});">
                                    <span class="image-wrapper"><img class="logo" src="/images/layout/footer/cxo.png" alt="" /></span>
                                    <span class="text-wrapper">Business</span>
                                </a>
                            </li>
                            <li id="footer-logo-cso">
                                <a href="//cio.nl/security" title="CSO" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'footer_logo_cso'});">
                                    <span class="image-wrapper"><img class="logo" src="/images/layout/footer/cso.png" alt="" /></span>
                                    <span class="text-wrapper">Security</span>
                                </a>
                            </li>                                
                            <li id="footer-logo-itlibrary">
                                <a href="//itlibrary.nl" title="IT Library" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'footer_logo_itlibrary'});">
                                    <span class="image-wrapper"><img class="logo" src="/images/layout/footer/itlibrary.png" alt="" /></span>
                                    <span class="text-wrapper">Resources</span>
                                </a>
                            </li>
                            <li id="footer-logo-itqa">
                                <a href="//itqa.nl" title="IT Q&amp;A" onclick="ga('send', {'hitType':'event','eventCategory':'articleView','eventAction':'click','eventLabel':'footer_logo_itqa'});">
                                    <span class="image-wrapper"><img class="logo" src="/images/layout/footer/itqa.png" alt="" /></span>
                                    <span class="text-wrapper">Vraag &amp; antwoord</span>
                                </a>
                            </li>
                        </ul>
                    </div>
                    <div class="text">
<div id="idgFooterWrapper">
    <div id="idgFooter" class="clearfix">
        <div id="idgFooterLogo">
                        <a href="http://idg.nl">
                <img alt="International Data Group" src="/images/layout/idg-logo.png" />
            </a>
        </div>
        <div id="idgFooterInfo">
            <ul>
                <li id="idgFooterCopyright">Copyright IDG Benelux - Alle rechten voorbehouden</li>
                <li id="idgFooterProducts">
                    IDG Benelux is uitgever van
                    <a href="http://cio.nl" target="_blank" title="CIO">CIO</a>,
                    <a href="http://computerworld.nl" target="_blank" title="Computerworld">Computerworld</a>,
                    <a href="http://csoonline.nl" target="_blank" title="CSO">CSO</a>,
                    <a href="http://cxo.nl" target="_blank" title="CXO">CXO</a>,
                    <a href="http://itlibrary.nl" target="_blank" title="IT Library">IT Library</a>,
                    <a href="http://itqa.nl/" target="_blank" title="IT Q&amp;A">IT Q&amp;A</a>,
                    <a href="http://webwereld.nl" target="_blank" title="Webwereld">Webwereld</a>,
                    <a href="http://summit.cio.nl/" target="_blank" title="CIO Summit">CIO Summit Series</a> en
                    <!-- <a href="http://itinnovationweek.nl/" target="_blank" title="IT Innovation Week">IT Innovation Week</a>,-->
                    <a href="http://cxosummit.nl/" target="_blank" title="IT Innovation Day">CXO Summit</a>
                    <!-- <a href="http://itsmartcities.nl/" target="_blank" title="IT Smart Cities">IT Smart Cities</a>

                    <a href="http://meetit2015.nl/" target="_blank" title="MEETIT">MEETIT</a> -->
                </li>
                <li id="idgFooterCustomerInfo">
                    Meer informatie:
                    <a href="https://idg.nl" target="_blank">IDG Benelux</a>,
                    <a href="https://www.idg.com" target="_blank">IDG.com</a>,
                    <a href="https://idg.nl/privacy-policy" target="_blank">Privacy Policy</a>,
                    <a href="https://idg.nl/cookiebeleid" target="_blank">Cookiebeleid</a>
                    (<a href="https://idg.nl/cookiebeleid-informatiepagina" target="_blank">meer info</a>),
                    <a href="javascript:window.admiral('show','cmp.settings');">Cookievoorkeuren openen</a>
                </li>
                <li id="idgFooterHostingInfo">
                    <a href="https://www.true.nl/managed-hosting/" target="_blank"><img src="/images/footer/hosted-by-true.png" alt="Hosted by TRUE" /></a>
                </li>
            </ul>
        </div>
    </div>
</div>                    </div>
                </footer>
                <!-- End of footer -->
                <!-- This is the overlay which is displayed when the side-menu opens up -->
                <div id="navigation-overlay"></div>
            </div>
        </div>
        <!-- Overlays -->
        <div id="overlay-wrapper">
    <div id="overlay">
            <div id="search-overlay" class="wrapper">

    <a id="search-close"><span class="icon-close"></span></a>
    <input id="search-field" type="text" placeholder="Type hier om te zoeken..." />
    
    <p id="search-info"></p>
    <!--<ul id="search-results"></ul>-->
    
    <iframe id="search-results" src="" height="1000px" width="100%" frameborder="0" style="display:none">
    </iframe>
    
    <script>
    
        function resizeSearchResultsIframe()
        {
            var newHeight = $(window).height() - 300;
            if(newHeight < 100)
            {
                newHeight = 100;
            }   
            $('iframe#search-results').css({'height' : newHeight + 'px'});
        }
        
        $(window).resize(resizeSearchResultsIframe);
        
        setTimeout(resizeSearchResultsIframe, 1000);
    
    </script>

</div>

            <div id="video-overlay" class="wrapper">
    </div>
            <div id="embed-overlay">
    <div id="embed-frame"></div>
</div>            <div id="gallery-overlay">

    <div id="gallery-overlay-close-button">
        <img src="/images/overlay-close.png" />
        <span id="gallery-overlay-close-button-text">Sluiten</span>
    </div>

    <div id="gallery-wrapper">

        <div id="gallery-content">

            <div id="gallery-nav-left">
                <span class="icon-arrow-left5"></span>
            </div>
            
                <div id="gallery-selected-image-wrapper">
                    <div id="gallery-selected-image">

                    </div> 
                </div> 

            <div id="gallery-nav-right">
                <span class="icon-arrow-right5"></span>
            </div>
        </div>

        <div id="mpu-wrapper">
            <!--  DFP ad #ad_mpu_video -->
<div id="ad_mpu_video" class="mpu_video adsBlock">
</div>
<script type="text/javascript">
    $('#ad_mpu_video').responsiveAd({screenSize:'all', scriptTags: []});
</script>
<!--  end DFP ad #ad_mpu_video -->
            <div id="gallery-title"></div>
            <div id="gallery-summary"></div>
        </div>
        
        <div id="gallery-image-caption"></div>

        <div id="thumbnail-wrapper">
            <ul id="gallery-thumbnails"></ul>
        </div>

    </div>


</div>

            </div>
</div>        <!-- End of overlays -->

        <script>
                            function checkAdBlocker() {
                    //var status = $('.adsBlock:visible').length == 0;
                    var adBlockStatus = (typeof(adsAreShown) == 'undefined');
                    var adBlockMsg = adBlockStatus? 'On (ads blocked)' : 'Off (ads shown)';
                    ga('send', { 'hitType': 'event', 'eventCategory': 'AdBlocker', 'eventAction': adBlockMsg, 'eventLabel': adBlockMsg, 'nonInteraction': 1 });
                    if(adBlockStatus)
                    {
                        $('#we-re-not-angry-just-a-little-disappointed').show();
                    }
                    return adBlockStatus;
                }

                $(document).ready(checkAdBlocker);
                        
            $(window).load(function(){
                $('.image-wrapper').find('img').each(function(){
                    var imgClass = (this.width/this.height > 1) ? 'wide' : 'tall';
                    $(this).addClass(imgClass);
                });
            });
        </script>
        
        
        <!-- LinkedIn audience script/pixel -->
        <script type="text/javascript">var _linkedin_data_partner_id = '81399';</script><script type="text/javascript">
        (function(){var s = document.getElementsByTagName("script")[0]; var b = document.createElement("script"); b.type = "text/javascript"; b.async = true;
        b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js"; s.parentNode.insertBefore(b, s);})();
        </script><noscript><img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=81399&fmt=gif" /></noscript>
        <!-- end Linkedin audience script/pixel -->
        
    </body>
</html>
